To Fix Error “Require TLS 1.1 for HTTPS connections” of MavensMate v6.0

Well, you may have found that MavensMate shows an error “Server raised fault: ‘UNSUPPORTED_CLIENT: TLS 1.0 has been disabled in this organization. Please use TLS 1.1 or higher when connecting to Salesforce using https.” as below, if you are using MavensMate v6.0 in Sublime Text 3,which is because Salesforce disabled TLS 1.0 encryption recently, for more details you can take a look at HERE
MavensMate Error To fix this, upgrading MavensMate to v7.0(Beta) seems the only way for now, as the following:

Install MavensMate-app

First, The lastest MavensMate-app must be installed and be running alongside of Sumlime Text, you can download it from HERE

Upgrade MavensMate

In order to install the v7 betas, you must add “MavensMate” to your Package Control “install_prereleases” user setting, see below:
Package Controll Setting MavensMate install_prereleases Upgrade Package


After configure mm_workspace setting, you can use MavensMate as normal right now.


Require TLS 1.1 for HTTPS setting Require TLS 1.1 for HTTPS workspace

Enjoy It!

Related Post

Setup an awesome Salesforce developer environment ... Why Sublime Text 3 ? I've been working with for about 2 years, and always using IDE(See here, Eclipse IDE Installation)as my development environment. I don't think it is difficult to use, but it could more friendly. For example: 1. It doesn't support APEX an...
Batch Apex running mode (parallel and series) and ... In my early post, I’d shared about how to write a Schedulable Batch Apex in Salesforce, and I’ll show you how transactions run in batch Apex and how to maintain their state across these transactions in this post. Batch Apex running mode (parallel / series) As we know, each execution of a batch...
Using Custom Metadata Types and Custom Settings in... Custom Metadata is one of the new features that released at Summer'15 of Salesforce, which is customizable, deployable, packageable, and upgradeable application metadata, and it supports the following custom field types.   • Checkbox   • Date   • Date and Time  ...
Salesforce Mass Editor (Chrome Extension) – ... This's my second Chrome Extension (First one is HERE) this year, named "Salesforce Mass Editor" and it supports for doing the below things : ・Makes any Salesforce list view to be a powerful mass editor. ・Mass insert, mass clone, mass update, mass delete, ALL-IN-ONE. ・Export record data to CSV fi...